1. Difficulty
Link aggregation, link aggregation can increase the bandwidth of the link. Theoretically, through link aggregation, the maximum bandwidth of an aggregated port can be the sum of the bandwidths of all member ports.
Link aggregation brings together two or more physical ports to form a logical port that appears as a single higher-bandwidth logical link.
Link aggregation is generally used to connect one or more devices with large bandwidth requirements, such as servers or server groups connected to a backbone network. It can be used to extend link bandwidth and provide higher connection reliability.
The company has two floors, each running different businesses. Originally, the networks on the two floors were separate, but it is inevitable that the same company will have business contacts. At this time, we can open up the networks on the two floors to make them interconnected. high-speed communication between departments.
As shown in the figure above, SwitchA and SwitchB are connected to the networks of VLAN10 and VLAN20 respectively through Ethernet links, and there is a large amount of data traffic between SwitchA and SwitchB. Users hope that SwitchA and SwitchB can provide larger link bandwidth to enable communication between the same VLANs. At the same time, users also hope to provide a certain degree of redundancy to ensure the reliability of data transmission and links.
2. What is the configuration idea?
1) Create an Eth-Trunk interface and add member interfaces to increase link bandwidth.
2) Create a VLAN and add the interface to the VLAN.
3) Configure the load balancing method to realize load sharing of traffic among the member interfaces of the Eth-Trunk to increase reliability.
We take the configuration of Huawei s5700 switch as an example (s5700 is often used as the core switch of the project)
3. Implement configuration steps
1) Create Eth-Trunk interfaces on SwitchA and SwitchB and add them to member interfaces.
<Quidway> system-view
[Quidway] sysname SwitchA
[SwitchA] interface eth-trunk 1 //Create an Eth-Trunk interface with ID 1
[SwitchA-Eth-Trunk1] trunkport gigabitethernet 1/0/1 to 1/0/3 //Add three member interfaces GE1/0/1 to GE1/0/3 to the Eth-Trunk1 interface
[SwitchA-Eth-Trunk1] quit
<Quidway> system-view
[Quidway] sysname SwitchB
[SwitchB] interface eth-trunk 1 //Create an Eth-Trunk interface with ID 1
[SwitchB-Eth-Trunk1] trunkport gigabitethernet 1/0/1 to 1/0/3 //Add to Eth-Trunk1 interface
Three member interfaces GE1/0/1 to GE1/0/3
[SwitchB-Eth-Trunk1] quit
2) On SwitchA and SwitchB, create a VLAN and add the interface to the VLAN
# Create VLAN10 and VLAN20 and add them to the interfaces respectively.
[SwitchA] vlan batch 10 20
[SwitchA] interface gigabitethernet 1/0/4
[SwitchA-GigabitEthernet1/0/4] port link-type trunk //Set the interface link type to trunk. The default link type of the interface is not trunk port.
[SwitchA-GigabitEthernet1/0/4] port trunk allow-pass vlan 10
[SwitchA-GigabitEthernet1/0/4] quit
[SwitchA] interface gigabitethernet 1/0/5
[SwitchA-GigabitEthernet1/0/5] port link-type trunk //Set the interface link type to trunk. The default link type of the interface is not trunk port.
[SwitchA-GigabitEthernet1/0/5] port trunk allow-pass vlan 20
[SwitchA-GigabitEthernet1/0/5] quit
[SwitchB] vlan batch 10 20
[SwitchB] interface gigabitethernet 1/0/4
[SwitchB-GigabitEthernet1/0/4] port link-type trunk //Set the interface link type to trunk. The default link type of the interface is not trunk port.
[SwitchB-GigabitEthernet1/0/4] port trunk allow-pass vlan 10
[SwitchB-GigabitEthernet1/0/4] quit
[SwitchB] interface gigabitethernet 1/0/5
[SwitchB-GigabitEthernet1/0/5] port link-type trunk //Set the interface link type to trunk. The default link type of the interface is not trunk port.
[SwitchB-GigabitEthernet1/0/5] port trunk allow-pass vlan 20
[SwitchB-GigabitEthernet1/0/5] quit
# On SwitchA and SwitchB, configure the Eth-Trunk1 interface to allow VLAN10 and VLAN20 to pass.
[SwitchA] interface eth-trunk 1
[SwitchA-Eth-Trunk1] port link-type trunk //Set the interface link type to trunk. The default link type of the interface is not trunk port.
[SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20
[SwitchA-Eth-Trunk1] quit
[SwitchB] interface eth-trunk 1
[SwitchB-Eth-Trunk1] port link-type trunk //Set the interface link type to trunk. The default link type of the interface is not trunk port.
[SwitchB-Eth-Trunk1] port trunk allow-pass vlan 10 20
[SwitchB-Eth-Trunk1] quit
3) On SwitchA and SwitchB, configure the load balancing mode of Eth-Trunk1.
[SwitchA] interface eth-trunk 1
[SwitchA-Eth-Trunk1] load-balance src-dst-mac //Configure Eth-Trunk1 to perform load balancing based on the source MAC address and destination MAC address.
[SwitchA-Eth-Trunk1] quit
[SwitchB] interface eth-trunk 1
[SwitchB-Eth-Trunk1] load-balance src-dst-mac //Configure Eth-Trunk1 to perform load balancing based on the source MAC address and destination MAC address.
[SwitchB-Eth-Trunk1] quit
4) Verify the configuration results.
Run the display eth-trunk 1 command in any view to check whether the Eth-Trunk is created successfully and whether the member interfaces are correctly added.
[SwitchA] display eth-trunk 1
From the above information, we can see that Eth-Trunk 1 contains three member interfaces: GigabitEthernet1/0/1, GigabitEthernet1/0/2, and GigabitEthernet1/0/3. The status of the member interfaces is Up. The "Operate status" of Eth-Trunk 1 is up.
Contact: Mr.Molle
Phone: 18823647757
E-mail: info@opticsswitch.com
Whatsapp:8618823647757
Add: A508, Hedi Chuangke Building, No. 28 Qingshui Road, Longgang District, Shenzhen, Guangdong Province, China
We chat